netstatus_event_get_http_proxy_login_required()

This function has been deprecated.

Synopsis:

#include <bps/netstatus.h>
 
BPS_API bool netstatus_event_get_http_proxy_login_required(bps_event_t *event) BPS_DEPRECATED

Since:

BlackBerry 10.2.0

Arguments:

event

The NETSTATUS_INFO event to get the HTTP proxy information from.

Library:

libbps (For the qcc command, use the -l bps option to link against this library)

Description:

Deprecated:

This function has been deprecated - use netstatus_event_get_info() and netstatus_info_get_http_proxy_login_required().

The netstatus_event_get_http_proxy_login_required() function indicates whether login information is required for HTTP proxy from the specified NETSTATUS_INFO event. If login information is required, call netstatus_get_proxy_details() to get the user and password to log in with.

Returns:

true if login information is required for HTTP proxy, false otherwise.

Last modified: 2014-05-14



Got questions about leaving a comment? Get answers from our Disqus FAQ.

comments powered by Disqus