Satisfying FIPS 140-2 requirements

Using Security Builder Engine for OpenSSL can allow OpenSSL based applications to satisfy FIPS 140-2 requirements.

To achieve compliance, you must:

  • Enable only accepted protocols and cipher suites.
  • Call only those OpenSSL APIs that can be configured to use Security Builder Engine for OpenSSL for their underlying algorithm implementation.

The following sections detail the OpenSSL APIs that can and can't be configured to use Security Builder Engine for OpenSSL (and therefore, the APIs that you can and can't use within an application that must satisfy FIPS 140-2 requirements).

Last modified: 2015-07-24



Got questions about leaving a comment? Get answers from our Disqus FAQ.

comments powered by Disqus