Explore the Momentics IDE

The Momentics IDE for BlackBerry is the key development tool used for creating applications using the BlackBerry 10 Native SDK. If you have experience with Eclipse, most of the features of the IDE should be familiar to you.

The Momentics IDE includes all of the tools that you need to start developing applications for BlackBerry 10 devices, including a compiler, a linker, and command-line tools. When you start the Momentics IDE, you can download and install the BlackBerry 10 Native SDK from within the IDE.

The workbench and perspectives

When you start the Momentics IDE for BlackBerry for the first time, the Workspace Launcher dialog box prompts you for a location to store your workspace. All of your projects are stored in this folder.

Screen showing the Workspace Launcher in the Momentics IDE.

When you have selected a workspace, the Welcome page is displayed in the workbench. You can use this page to access key resources, such as sample apps and support forums. You can access this page by clicking Help > Open Welcome Page.

Learn more about the workbench, perspectives, and views

Read more

A workbench is the basic UI of the IDE and consists of perspectives, views, and editors for working with your resources.

A perspective defines the views that you see in the UI and the layout of the views in the workbench. You can access a perspective using Window > Open Perspective. You can change the layout of a perspective by opening and closing views, or by docking views in different positions in the workbench window.

Views are windows that appear in the perspective and present information about your projects. For example, the Project Explorer view displays projects and resources that you are working with. You can access individual views using Window > Show View.

You can use some key perspectives for basic activities in the IDE. Depending on the type of app you are creating or the stage of your development, you may choose to work in a different perspective.

Learn more about key perspectives

Read more
  • The QML Editing perspective provides QML support for Cascades projects.

    To open the QML Editing perspective, click Window > Open Perspective > Other. Click QML Editing, and click OK. To learn more, see The QML Editing perspective.

  • The C/C++ perspective can be used for C and Cascades projects.

    This perspective is the default, but if it isn't displayed, you can open it by clicking Window > Open Perspective > C/C++. To learn more, see The C/C++ perspective.

  • The Debug perspective shows you all of the tools related to debugging. The Debug perspective opens automatically when you select Debug in the Launch mode drop-down list and click Momentics IDE Launch button..

    To learn more, see Testing and debugging.

  • The QNX System Information perspective provides a complete and detailed report on your system's resource allocation and use.

You can configure the appearance and behavior of your application by specifying properties and values in the bar-descriptor.xml file.

Learn more about the bar-descriptor.xml file

Read more

The bar-descriptor.xml specifies parameters for identifying, installing, and running applications on the BlackBerry 10 OS and is also used to specify permissions. To learn more, see The bar-descriptor.xml file.

Last modified: 2014-11-17



Got questions about leaving a comment? Get answers from our Disqus FAQ.

comments powered by Disqus