<platformVersion>

(Required) The minimum version of the BlackBerry 10 OS version on which the application can be installed and run.

Parent elements:

<qnx>, <configuration>

Child elements:

None.

Description:

The <platformVersion> element specifies the minimum version of the OS on which the application can be installed and run, also referred to as the minimum OS version. The first three segments of the number indicate the minimum version you can compile your app against, which is referred to as the API level.

Content:

A PCDATA value representing the platform version. The value must be specified as a four-segment number; otherwise the value is not valid. The minimum API level is determined from the value specified for this element by omitting the last segment. The value that you specify indicates not only the minimum OS version that your app requires to run, but the minimum API level required to compile your app.

For example, if you specified the value of 10.2.0.1155, it indicates that the minimum OS version required for the app to run would be 10.2.0.1155 and the minimal API level to compile your code against would be BlackBerry 10.2.0 (or BlackBerry 10.2).

Attributes:

None.

Example:

<platformVersion>10.2.0.1155</platformVersion>     
                    

Last modified: 2014-11-17



Got questions about leaving a comment? Get answers from our Disqus FAQ.

comments powered by Disqus