Step into disassembled code

You can examine your app as it steps into functions that you don't have source code for, such as printf. Normally, the debugging tool steps over these functions, even when you click Step Into. When the instruction pointer enters functions that it doesn't have the source code for, the Momentics IDE shows the function in the Disassembly view.

In the Disassembly view, you can jump to any memory address to view the section of disassembly, starting at a specified memory address (a hexadecimal or decimal value). The Momentics IDE for BlackBerry queries the debugging tool for the disassembly for that memory address, and then refreshes the view to show a section of disassembly starting with that address.

  1. On the Window menu, click Show View > Disassembly.

    The workbench adds the Disassembly view to the Debug perspective:

    Screen showing the Disassembly view.

  2. To set the focus to the Disassembly view, do one of the following:
    • Click the Disassembly view.
    • On the Debug view toolbar, click Toggle Instruction Stepping.

      The operators, such as Run to Line, run on machine instructions instead of the source code.

  3. To jump to an address in memory, click the View Menu icon in the Disassembly view, and then select Go to Address.Screen showing the menu in the Disassembly view, with the Go to Address option selected.
  4. In the Go to Address dialog box, type the memory address as a hexadecimal value (prefixed with 0x), and then click OK.

Last modified: 2014-06-24



Got questions about leaving a comment? Get answers from our Disqus FAQ.

comments powered by Disqus