Would you like to tell us how we are doing?

You bet No thanks

Updating the BlackBerry 10 Dev Alpha Device Software

Before you begin: If you need to backup your device data, back it up before performing this upgrade.


Please be sure to create a second BlackBerry ID for your Dev Alpha device. If you use your existing BlackBerry ID, all BBM contacts could be transferred from your current BlackBerry device to your Dev Alpha device and they will be erased from your current BlackBerry device.

OS Autoloaders for Windows

Need a different version?

STL100-1 Autoloader 10.3.1.997 (1.77 GB)
  1. Download the appropriate Autoloader above. Your model number can be found under Settings › About › Model Number

  2. Turn off your BlackBerry 10 Dev Alpha device.

  3. Run the downloaded Autoloader file.

  4. When prompt shows “Connecting to Bootrom”, connect your device to your computer and turn it on.

  5. If you have a password set on your device, type your password when prompted.

  6. After your device restarts, complete the set up wizard.


Note: You may attempt to load the latest Dev Alpha B update onto your Dev Alpha A, however the The Dev Alpha A is no longer officially supported as of 10.1.0.1485. If you encounter any issues please downgrade back to 10.0.10.263 using the Autoloader method. You can download the old 10.0.10.263 Autoloader here.

The 10.3 SDK OS (10.3.0.442) is also being made available to those developers who would like to test on their BlackBerry 10 device. You'll need to find your device model number and then download the corresponding Autoloader above. The model number can be found under Settings › About › Model Number.

This SDK OS update is only for testing purposes and does not replace your full BlackBerry 10 OS. To revert your BlackBerry 10 device to a public OS release, please follow the steps outlined in this Knowledge Base Article. Using BlackBerry Link, you will be able to reload your device software to a full OS and, if needed, download any OS updates from your carrier.

A Mac OS X version of the Autoloader is not available at this time. Users wishing to upgrade will need to locate a Windows compatible machine.