Sorry about the red box, but we really need you to update your browser. Read this excellent article if you're wondering why we are no longer supporting this browser version. Go to Browse Happy for browser suggestions and how to update.

Setting up your development environment

Both the BlackBerry Java Plug-in for Eclipse and the BlackBerry Java Development Environment support development of BlackBerry Messenger connected applications.

Create a project for your BBM connected application using the BlackBerry Java Plug-in for Eclipse

  1. In Eclipse, open the BlackBerry Application Development perspective.
  2. Click File > New > BlackBerry Project.
  3. In the New BlackBerry Project dialog box, in the Project Name field, type a name for your project.
  4. In the JRE section, make sure you select a BlackBerry JRE that is version 5.0 or later, and click Finish.
  5. In the Package Explorer view, right-click the project and click Properties.
  6. In the Properties dialog box, in the left pane, click Java Build Path.
  7. Click the Libraries tab.
  8. Click the Add External JARs button.
  9. Navigate to the folder where you extracted the BlackBerry Messenger SDK file. In the BBM SDK folder, double-click net_rim_bb_qm_platform.jar.
  10. Click Next.
  11. In the properties window, click OK.
  12. When you are ready to build your project, on the Project menu, click BlackBerry > Package All.
After you finish:

To test your application, see Running your BBM connected app.

Create a workspace for your BBM connected application using the BlackBerry Java Development Environment

Before you begin: In the folder where you extracted the BlackBerry Messenger SDK, copy net_rim_bb_qm_platform.jar from the BBM SDK folder to the lib folder of the BlackBerry Java Development Environment (the default location of the lib folder is C:\Program Files\Research In Motion\BlackBerry JDE 6.0.0\lib).
  1. In the BlackBerry JDE, click File > New Workspace.
  2. In the Workspace Name field, type a name for the workspace and click OK.
  3. Right-click the workspace and click Properties.
  4. In the Workspace Properties dialog box, in the General tab, beside the Imported Jar Files list, click Add.
  5. In the Add file dialog box, navigate to C:\Program Files\Research In Motion\BlackBerry JDE 6.0.0\lib and double click the net_rim_bb_qm_platform.jar file. The file appears in the Imported Jar Files list in your workspace properties. You can now import the BlackBerry Messenger classes and compile your application.
  6. Right-click the workspace and perform one of the following actions:
    • To import an existing project, click Add Project to <workspace name>.
    • To create a new project, click Create new Project in <workspace name>.
  7. When you are ready to build your project, click the BlackBerry Smartphone Simulator profile drop-down list located in the top-right corner of the BlackBerry JDE. By default, the selected profile is Default Simulator.
  8. In the drop-down list, click 9800-6.0.0.313.
  9. On the Build menu, click Build. The .cod files for your application are created and placed in the simulators directory of the BlackBerry JDE.
After you finish:

To test your application, see Running your BBM connected app.