Would you like to tell us how we are doing?

You bet No thanks

Sorry about the red box, but we really need you to update your browser. Read this excellent article if you're wondering why we are no longer supporting this browser version. Go to Browse Happy for browser suggestions and how to update.

Setting BlackBerry Java Plug-in for Eclipse options

Specify the BlackBerry update site

  1. On the Help menu, click Install New Software.
  2. In the Available Software dialog box, click Add.
  3. In the Name field, type a name.
  4. In the Location field, type http://www.blackberry.com/go/eclipseUpdate/3.6/java or http://www.blackberry.com/go/eclipseUpdate/mac/java. Note: Do not type this URL into your browser's address bar.
  5. Click OK.
  6. Close the Install window.

Specify the default BlackBerry JRE

  1. In Eclipse, on the Window menu, click Preferences.
  2. Expand the Java item and click Installed JREs.
  3. In the Installed JREs list, select the BlackBerry JRE that you want to use as the default runtime environment.
  4. Click OK.

Specify the heap memory for Eclipse

If you work with large or numerous projects, or if you use the profiler application when you debug a BlackBerry device application, you should start Eclipse with more than the default amount of heap memory or permanent generation memory. Memory between 512Mb and 768Mb is recommended.

Complete one of the following tasks:

Task

Steps

Specify the amount of permanent generation memory in the eclipse.ini file.

  1. Navigate to the directory where you installed Eclipse.

  2. In the eclipse.ini file, change the following parameter:

    --launcher.XXMaxPermSize

    512m

Specify the amount of heap memory in the eclipse.ini file.

  1. Navigate to the directory where you installed Eclipse.

  2. In the eclipse.ini file, change the following parameter:

    -Xmx512m

Turn on application preprocessing

By default, preprocessing is turned on automatically when you create or import a BlackBerry application project (you must restart Eclipse). You can turn on preprocessing for your applications manually by updating the Eclipse configuration file.

  1. Browse to ...\<Eclipse-dir>\configuration (Windows), or .../BBEclipse/configuration (Mac OS), and open the config.ini file.
  2. Add the following line to the config.ini file:
    • osgi.framework.extensions=reference\:file\:net.rim.ejde.preprocessing.hook_1.3.0.<ver>/

If you turn on preprocessing after you build a project, on the Project menu, you must clean the project before you build the project again.

Enable functionality similar to the BlackBerry Java Development Environment

  1. Open the Eclipse workspace.
  2. On the Window menu, select Preferences.
  3. Expand the General item.
  4. Select the Workspace item.
  5. Clear the Build automatically option.
  6. Clear the Refresh automatically option.
  7. Select the Save automatically before build option.

Detect new versions of the BlackBerry Java Plug-in for Eclipse

When you start the BlackBerry Java Plug-in for Eclipse an update notification appears when a new version is available.

  1. In Eclipse, on the Window menu, click Preferences.
  2. In the left pane, click BlackBerry Java Plug-in.
  3. In the right pane, select the Notify about upgrades check box.
  4. Click OK.

To learn how to upgrade the BlackBerry Java Plug-in for Eclipse see http://developer.blackberry.com/java/download/eclipse