Sorry about the red box, but we really need you to update your browser. Read this excellent article if you're wondering why we are no longer supporting this browser version. Go to Browse Happy for browser suggestions and how to update.

Getting started with the BBM SDK

BlackBerry Messenger version dependencies

The following table shows the dependencies between versions of the BlackBerry Messenger SDK, BlackBerry Messenger, and BlackBerry Device Software. You can use this table to determine the minimum version of BBM and BlackBerry Device Software that are required to run your application.

BBM SDK version

BBM version

BlackBerry Device Software version

1.0

6.0.0

5.0 and later

1.2

6.0.1

5.0 and later

1.3

6.1.0

5.0 and later