Sorry about the red box, but we really need you to update your browser. Read this excellent article if you're wondering why we are no longer supporting this browser version. Go to Browse Happy for browser suggestions and how to update.

The BlackBerry Application Development perspective for Java

The BlackBerry Application Development perspective for Java gives you quick access to the development tools that you need to create BlackBerry device applications. The perspective provides a toolbar and a menu that bring the tools together in one place.

Open the BlackBerry Application Development perspective

  1. In Eclipse, on the Window menu, click Show Perspective > Other.
  2. Click BlackBerry Application Development.
  3. Click OK.

The BlackBerry menu

The BlackBerry menu provides you with easy access to the development tools for creating BlackBerry device applications. You can also access these tools from the toolbar in the BlackBerry Application Development perspective or by right-clicking a BlackBerry application project to display the context menu.

Clean simulator (Windows only)
Restores a BlackBerry Smartphone Simulator to the default settings.
New > BlackBerry Project
Creates a new BlackBerry application project.
New > BlackBerry Screen
Creates a new UI screen.
New > BlackBerry Resource
Creates a new resource file.
Import > BlackBerry Samples
Imports sample BlackBerry applications into the Eclipse workspace.
Import > Eclipse BlackBerry Project
Imports a BlackBerry application project from a different Eclipse workspace.
Import > Legacy BlackBerry Projects
Imports a BlackBerry application project that you developed by using the BlackBerry Java Plug-in for Eclipse 1.0 or the BlackBerry Java Development Environment.
Package > Project(s)
Packages one or more BlackBerry application projects that you select.
Package > All
Packages all the projects in your workspace.
Package > Working Set
Packages a working set that you defined.
Sign > Sign with Signature Tool
Starts theBlackBerry Signature Tool.
Sign > Install new Keys
Opens the Install New Keys dialog box.
Sign > Import Existing Keys
Opens the Import Existing Keys dialog box.
Sign > Remove Existing Keys
Opens the Remove Existing Keys dialog box.
Run as > BlackBerry Smartphone Simulator
Opens your application in the BlackBerry Smartphone Simulator.
Run as > Run Configurations
Opens the Run Configurations dialog box.
Debug as > BlackBerry Device
Opens your application for debugging on a BlackBerry device.
Debug as > BlackBerry Smartphone Simulator
Opens your application for debugging on a BlackBerry Smartphone Simulator.
Debug as > BlackBerry Smartphone Simulator (running)
Opens your application for debugging on a BlackBerry Smartphone Simulator that is already running.
Load Project(s) on Device
Loads your application on a BlackBerry device.
Analysis Tools > BlackBerry Memory Statistics View
Opens the BlackBerry Memory Statistics View.
Analysis Tools > BlackBerry Objects View
Opens the BlackBerry Objects View.
Analysis Tools > BlackBerry Profiler View
Opens the BlackBerry Profiler View.
Open BlackBerry World page
Opens the BlackBerry World storefront webpage.
Open BlackBerry Getting Started Page
Opens the BlackBerry developer documentation page.

The BlackBerry toolbar

The BlackBerry toolbar provides you with easy access to the development tools that you use most often to create BlackBerry device applications.


A screen shot of the BlackBerry toolbar.

Tool

Menu icon

Description

New BlackBerry Project


The New BlackBerry Project toolbar button.

Creates a new BlackBerry application project

Import Samples


The Import Samples toolbar button.

Imports BlackBerry sample applications into the Eclipse workspace

Clean Simulator (Windows only)


The Clean Simulator toolbar button.

Restores a BlackBerry Smartphone Simulator to the default settings

Open Help Contents


The Open Help toolbar button.

Opens the online help

Open BlackBerry World Page


The Open BlackBerry World toolbar button.

Opens the BlackBerry World storefront webpage

Open BlackBerry Getting Started Page


The Open BlackBerry Getting Started Page toolbar button.

Opens the BlackBerry developer documentation page

Run on BlackBerry Simulator (Windows only)


The Run on BlackBerry Simulator toolbar button.

Runs your application on the BlackBerry Smartphone Simulator

Debug on BlackBerry Simulator (Windows only)


The Debug on BlackBerry Simulator toolbar button.

Starts your application on the BlackBerry Smartphone Simulator for debugging