Would you like to tell us how we are doing?

You bet No thanks

Plug-in and command-line tools

System requirements

Before you proceed, review the following system requirements to make sure you have the minimum hardware and software components needed to repackage your .apk files as .bar files.

Item

Requirement

Hardware

Memory: 4 GB RAM or more

Monitor resolution of 1024 x 768 or higher

Intel Pentium 4 or AMD Athlon 2 GHz (or faster)

1 GB (or more) available hard disk space

Software

Eclipse (Luna) version 4.4

BlackBerry Plug-in for Android Development Tool 2.0.6

Android SDK tools 23.0

Android API levels required by your apps.

The maximum API level supported is Android 4.3 (API 18).

Java Runtime Environment 1.8 (Java JRE 1.8) or Java SE JDK v1.8

Operating system

Windows 7 (64 bit), Windows 8.1 (64 bit)

Mac OS Mountain Lion, Mac OS Mavericks

Linux Ubuntu 14.04 (32 bit)

Virtual environment

VMware Player to run the BlackBerry 10 Device Simulator on Windows

VMware Fusion to run the BlackBerry 10 Device Simulator on Mac OS

Checking the compatibility of .apk files

Performing a compatibility check allows you to verify that your Android app is compatible with the BlackBerry 10 OS.

Some of the Android SDK APIs are not supported, or are only partially supported, by the BlackBerry Runtime for Android apps. Therefore, not all .apk files are fully compatible with BlackBerry 10 devices.

The 2.0 release version of the tools automatically check the compatibility of your .apk files before attempting to repackage them as .bar files. These tools help you assess the level of compatibility that your repackaged Android app has with the BlackBerry 10 OS.



Got questions about leaving a comment? Get answers from our Disqus FAQ.

comments powered by Disqus